redes

Configurar acceso a internet en máquina virtual con Ubuntu

En varias ocasiones, al virtualizar Ubuntu dentro de una máquina virtual (VirtualBox o VMWare), hay problemas con el internet. Ya sea que es por la IP, problemas de la máquina virtual o del sistema.

Por eso es que hoy voy a mostrarte cómo configurar y solucionar algunos problemas de las máquinas virtuales con Ubuntu y el internet, cuando se pierde la conexión o simplemente no existe.

También veremos cómo arreglar el mensaje que dice: noop state down group default qlen 1000

Continue reading…

APN Weex México: MCC y MNC

Introducción

Weex es una compañía telefónica que opera en méxico. En su página aparece cómo configurar el APN Weex, en donde nos da el nombre y el APN.

El problema viene cuando no nos brinda la información que va en algunos campos obligatorios como el MCC o el MNC. Sin dichos datos no podremos guardar la configuración.

Busqué mucho tiempo qué valores poner en los siguientes campos:

  • MCC
  • MNC
  • Tipo de autenticación
  • Nombre de usuario
  • Contraseña

No encontré mucha información al respecto o la solución exacta. Tampoco recuerdo ni dónde ni cómo, pero pude encontrar los faltantes y vengo a compartirlo.

Configurar MCC, MNC y todo lo demás en APN Weex

Recordemos que Weex utiliza las antenas de Movistar (o no sé qué cosa exactamente, no soy experto en esa área). Tomando en cuenta eso, intenté llenar los campos faltantes que Weex no proporciona con los de Movistar.

Los datos faltantes son los siguientes:

  • Nombre: Weex
  • APN: internet.weex.mx
  • Nombre de usuario: movistar
  • Contraseña: movistar
  • MCC: 334
  • MNC: 030
  • Tipo de autenticación: PAP
  • Tipo de APN: default

Abajo adjunto las capturas de pantalla que muestran la configuración en Android. Puedes abrirlas para ampliarlas y verlas en tamaño completo.

Captura 1 APN Weex

Captura 1 APN Weex

Configuración Captura 2

Configuración Captura 2

Paso 3 de configuración APN

Paso 3 de configuración APN

 

 

 

 

 

 

Ejercicios resueltos con Cisco: VTP y VLAN

Introducción

Hoy veremos un poco de VTP y configuración de VLANs. VTP propaga configuraciones en switches que pertenezcan al mismo dominio.

Nota: las contraseñas son cisco y class

Distribución de la red

Configurar el S1 como servidor VTP, asignar dominio y contraseña

Abrimos la CLI del S1 y ejecutamos:

enable
configure terminal
vtp mode server

Para el dominio, ahí mismo hacemos:

vtp domain CCNA

Y finalmente para la contraseña:

vtp password cisco

Con eso ya llevamos 7 %. Aquí la imagen de la CLI:

Configurar S2 y S3 como clientes, con mismo nombre de dominio y contraseña que S1

Lo mismo, sólo cambia el modo VTP  de server a client. Para el S2:

Los comandos son:

enable
conf t
vtp mode client
vtp domain CCNA
vtp password cisco

Ahora hacemos lo mismo en el S3:

Debemos llevar 30 % de la actividad.

Configurar VLAN en S1

Hora de crear las VLAN. Los comandos son:

enable
conf t
vlan 10
name Faculty/Staff
vlan 20
name Students
vlan 30
name Guest(Default)
vlan 99
name Management&Native

Aquí la imagen:

Se supone que este switch propagará las VLAN, así que no tenemos que crear las mismas VLAN en los demás switches.

El avance hasta ahora debe ser de 46 %.

Configurar los enlaces troncales en S1, S2 y S3

VLAN nativa y enlaces troncales de S1

Ejecutamos en el S1:

enable
conf t
int f0/1
switchport mode trunk
switchport trunk native vlan 99
int f0/3
switchport mode trunk
switchport trunk native vlan 99

Switch 2

Casi los mismos comandos, pero la nativa sólo va en la f0/1:

enable
conf t
int f0/1
switchport mode trunk
switchport trunk native vlan 99

Switch 3

Lo mismo que arriba pero en la f0/3 y en el switch 3:

enable
conf t
int f0/3
switchport mode trunk
switchport trunk native vlan 99

Con esto llevamos 76 % de la actividad.

Asignar VLAN a los puertos

Finalmente asignaremos los puertos del switch 2 y 3. Para ello…

Switch 2

enable
conf t
int f0/11
switchport mode access
switchport access vlan 10
int f0/18
switchport mode access
switchport access vlan 20
int f0/6
switchport mode access
switchport access vlan 30

Justo como se ve en la imagen:

Switch 3

Para terminar, hagamos lo mismo en el s3:

enable
conf t
int f0/11
switchport mode access
switchport access vlan 10
int f0/18
switchport mode access
switchport access vlan 20
int f0/6
switchport mode access
switchport access vlan 30

Como se ve en esta imagen:

Con esto ya estamos al 100 %.

Conclusión

Aquí la imagen comprobando los resultados:

Te invito a leer:

Ejercicios resueltos con Cisco: VLAN y enlaces troncales

Ejercicios resueltos con Cisco Packet Tracer parte 2: VLAN y enlaces troncales

Introducción

Ya tiene tiempo que resolví algunos ejercicios en Cico Packet tracer sobre VLSM. Hoy toca ver cómo configurar algunas VLAN y enlaces troncales.

Objetivos

  • Configurar las VLAN en los switches.
  • Configurar enlaces troncales en los switches.
  • Verificar la conectividad de extremo a extremo.

topología y distribución de red

Así se ve la red:

Tarea 1: configurar los dispositivos y verificar conectividad

Configure cada switch con las siguientes configuraciones básicas.
• Nombre de host (Para Switch 0 S1 y Para Switch 1 S2)
• Contraseña secreta de enable (class)
• Configuraciones de la línea (cisco)

Configurar Switch 0 (cero)

Nombre de host

Abrimos la CLI del switch y le ponemos su nombre:

enable
configure terminal
hostname S1

Así como en la imagen:

Con esto ya llevamos 3 % de la actividad.

Contraseña secreta

Escribimos en la misma CLI:

enable secret class

En este caso, class es la contraseña. Con esto ya llevamos 7 %

Configuraciones de la línea

Finalmente vamos a escribir en la CLI:

line console 0
password cisco
login

Ya llevamos 11 % completado.

Configurar Switch 1

Sigue los mismos pasos que llevamos a cabo para el switch 0. Abajo dejo una imagen de los comandos aplicados.

Recuerda que el nombre para el switch es S2.

Los comandos, juntos, son:

enable
configure terminal
hostname S2
enable secret class
line console 0
password cisco
login

Con esto, si es que lo hicimos bien, ya llevamos 23 % según yo.

Tarea 2: configurar las VLAN en los switches

Aquí viene lo bueno. Es hora de configurar las VLAN en cada switch.

Paso 1: cree y asigne un nombre a las VLAN

En cada switch, asignar los siguientes nombres:

• VLAN 2, nombre = INFORMATICA
• Para la VLAN 3, nombre = SISTEMAS
• Y en VLAN 4, nombre = MECATRONICA

Notar por favor que se tienen que poner en cada switch.

Switch 1 (que antes de renombrar era el cero)

Abrimos la CLI, si nos pide contraseña es cisco. Luego ejecutamos los siguientes comandos:

enable
configure terminal
vlan 2
name INFORMATICA
vlan 3
name SISTEMAS
vlan 4
name MECATRONICA

Cuando ejecutemos enable, nos pedirá una contraseña. Es class.

Se ve así:

Con esto ya llevamos 34 % de avance.

Switch 2

Exactamente lo mismo de arriba, pero en la CLI del S2:

Ya llevamos 46 % de avance 🙂

Paso 2: Asigne puertos de acceso a las VLAN

Asigne los siguientes puertos de acceso de las PC a las VLAN: (Revisa los puertos en la Topologia)
• VLAN 2: PC1, 2 en S1 y PC7 Y 8 en S2
• Para VLAN 3: PC3, 4 en S1 y PC9 Y 10 en S2
• En VLAN 4: PC5, 6 en S1 y PC11 Y 12 en S2

Esto sí se me hizo complicado al inicio, porque no dice qué puertos. No sabía por dónde empezar. Pero si nos damos cuenta, cada PC está conectada a través de las interfaces Fa0/X en donde X es el número de PC.

Veamos esta imagen, la PC 1 está en la Fa0/1:

Entonces la PC2 está en la Fa0/2 y así hasta la PC6:

Lo mismo para el segundo switch:

Hora de configurar.

Switch 1

Abrimos de nuevo la CLI. Si pide contraseña, ya la sabemos (si no, vuelve a leer el tutorial porque no has puesto atención).

Recuerda que vamos a asignar, sólo para este switch, lo siguiente:

  • En VLAN 2 la PC 1 y 2
  • Para VLAN 3 la PC 3 y 4
  • Finalmente, en VLAN 4 la PC 5 y 6

Para asignar la PC 1, que está en f0/1 a la VLAN 2, hacemos esto:

interface f0/1
switchport mode access
switchport access vlan 2

Para la PC 2, que está en f0/2 a la VLAN 2, esto:

interface f0/2
switchport mode access
switchport access vlan 2

Y así hacemos para asignar las otras computadoras a las otras VLAN’s:

interface f0/3
switchport mode access
switchport access vlan 3

interface f0/4
switchport mode access
switchport access vlan 3

interface f0/5
switchport mode access
switchport access vlan 4

interface f0/6
switchport mode access
switchport access vlan 4

Aquí una imagen:

Con esto ya llevamos 69 % de la actividad.

Switch 2

Lo mismo de arriba, pero recordemos que las VLAN y las PC’s van así:

  • PC 7 y 8 en VLAN 2
  • Luego, PC 9 y 10 en VLAN 3
  • Finalmente, la PC 11 y 12 en VLAN 4

Los comandos son:

enable
configure terminal

interface f0/7
switchport mode access
switchport access vlan 2

interface f0/8
switchport mode access
switchport access vlan 2

interface f0/9
switchport mode access
switchport access vlan 3

interface f0/10
switchport mode access
switchport access vlan 3

interface f0/11
switchport mode access
switchport access vlan 4

interface f0/12
switchport mode access
switchport access vlan 4

Aquí la imagen:

Con esto ya llevamos 92 % de la práctica.

Verificar la implementación de la VLAN

Para ver que todo haya ido bien, podemos ejecutar:

exit
exit
show vlan brief

En cada switch.

En el caso del S2 se ve esto:

Ya casi terminamos, ya casi.

Paso 3: Configurar modo de puerto para ambos switches

No soy un experto en redes y no planeo serlo, así que no sé para qué se tiene que hacer esto pero tenemos que ejecutar algunos comandos finales en cada switch.

Al hacer la práctica y verificar los resultados, todo va bien excepto por lo que está en rojo:

Así que en la interfaz 0/24 de cada switch había algo malo. Y es en donde me di cuenta de que hay que configurar el modo de puerto.

Switch 1

Abrimos la CLI y ejecutamos:

enable
configure terminal
interface f0/24
switchport mode trunk

Aquí una imagen:

Switch 2

Lo mismo:

enable
configure terminal
interface f0/24
switchport mode trunk

Aquí la imagen:

Con esto hemos terminado.

Conclusión

Aquí la imagen que comprueba que hemos cumplido todo lo de la práctica y estamos al 100 % de la actividad:

 

Instalar y configurar FileZilla Server [Servidor FTP] versión 0.9.60.2 en Windows

Introducción

Hoy necesitaba respaldar algunos ficheros de una computadora que tenía que formatear. Entré con un live cd y todo bien, pero para copiar todos esos archivos tenía que sacar el disco duro, usar una memoria usb, o algo parecido.

Así que pensé en una solución más “limpia” y confiable, sin mover nada y sin depender del sistema operativo. Por lo que decidí usar FTP.

Afortunadamente el cd vivo que utilicé ya tenía un cliente FTP, pero ahora lo que importaba era instalar un servidor FTP en la computadora en donde guardaría el respaldo. Buscando, encontré FileZilla. Y por eso es que escribo este tutorial.

Descargando

Vamos a la página https://filezilla-project.org/download.php?type=server y hacemos click en Download FileZilla Server. Esperamos a que se termine la descarga y guardamos en un lugar fácil de recordar

Instalando

Ahora ejecutamos como administrador el fichero que descargamos. Primero, aceptamos la licencia

 

Aquí seleccionamos los componentes. Por defecto se instala el servicio; es decir, el servidor propiamente dicho. La interfaz de administración, y los accesos directos para abrir el programa. También podemos instalar el código fuente, pero no es necesario

 

En este apartado se configura la ruta de instalación. Recomiendo no tocarla y dejarla tal y como está

 

Ahora vamos a elegir cómo debería ser iniciado. Lo recomendable es instalarlo como un servicio de Windows (para que inicie junto con el sistema y para que Windows se encargue del servicio).

Abajo nos pide el puerto que será utilizado para administrar el servidor. Ojo: este no es el puerto que usarán los clientes para conectarse, sino nosotros mismos para administrar el servidor. Recomiendo dejarlo como está, y si lo cambiamos hay que recordar el puerto elegido.

Aquí igualmente dejamos los ajustes como están. Por defecto iniciará la interfaz del servidor cuando el usuario inicie sesión

 

 

Esperamos a que se instale…

 

 

Una vez que termine, lo cerramos. Y se iniciará la interfaz. Con esto hemos terminado la instalación.

Configuración del servidor

Muy bien, nuestro servidor ya está instalado y esperando clientes. Pero falta configurarlo.

La interfaz nos mostrará una ventana para ingresar los datos de acceso para administrar el servidor.

Por defecto es en localhost, en el puerto que elegimos anteriormente. Podemos, si queremos, establecer una contraseña.

También somos capaces de marcar “Always connect to this server” para que no nos vuelva a aparecer esa ventana y tome los ajustes que dejemos la primera vez.

Como sea, una vez que hayamos puesto los ajustes hacemos click en Connect.

Usuarios

Comencemos con los usuarios, pues sin usuarios no hay nada que hacer. Hacemos click en el icono de un usuario.

Saldrá lo siguiente:

Hacemos click en Add y vamos a crear nuestro primer usuario.

El usuario puede ser cualquiera, aunque no recomiendo poner espacios o caracteres extraños. Una vez hecho eso, hacemos click en OK.

  1. Los ajustes de la cuenta. Aquí podemos establecer una contraseña para el usuario. Si no marcamos la casilla, no hay problema. Aunque recomiendo siempre establecer una contraseña segura.
  2. Límites de conexiones. Podemos limitar el número de conexiones que ese usuario hace.
  3. Descripción. Una pequeña descripción del usuario. Advertencias, recordatorios, etcétera.
  4. Administración del usuario. Eliminarlo, cambiar el nombre, copiarlo o agregar uno nuevo.

En este caso a mi usuario lo configuré con una contraseña, y no le puse límites. Por lo que queda así:

Con esto ya configuramos un usuario. Podemos configurar los que deseemos. En el siguiente apartado veremos cómo dar permiso a estos usuarios para que puedan acceder a determinadas carpetas y, dentro de ellas, manejar permiso para leer y escribir.

Nota: no cierres la ventana de configuración

Carpetas compartidas

Un servidor FTP se compone de 2 cosas: usuarios y carpetas o folders. Si no, no sirve de nada. Ahora vamos a configurar las carpetas.

En la configuración del usuario ahora vamos a Shared folders

Ahí veremos lo siguiente, en donde agregaremos una nueva carpeta para que sea accedida por FTP.

Se abrirá una ventana para seleccionar la carpeta. En mi caso compartiré “Documentos” para ejemplificar. Pero podemos compartir cualquiera.

Ahora vamos a configurar los permisos:

  1. Podemos agregar otros directorios, eliminarlos o renombrarlos.
  2. Permisos de archivos. Read es leer, es decir, ver los ficheros. Write es tanto crear nuevos archivos como editarlos y guardar cambios. Finalmente, delete es eliminar los archivos. Cuidado con este último ajuste, pues los archivos se eliminarán permanentemente.
  3. Permisos de directorios. Lo mismo que los ficheros, sólo que Read ahora es List. La opción de subdirs es para que esos cambios apliquen a los directorios o carpetas dentro de esa carpeta. Si deshabilitamos esto, el usuario no podrá entrar a las carpetas; sólo podrá ver lo que hay en la carpeta raíz que estamos compartiendo.
  4. Permisos de usuarios, que ya vimos más arriba.

En este caso quiero que “luis” sea un usuario administrador, excepto por una cosa: que no pueda eliminar. Así que marcaré todo excepto dicha opción. La configuración final queda así:

Límites de velocidad

Pasando a la tercera opción, speed limits, podemos configurar los límites de velocidad; tanto de subida como de bajada. Esto lo explicaré en otro tutorial

Filtros de IP

Aquí, en la cuarta opción, podemos bloquear ips. Así, aunque el usuario exista y tenga credenciales correctas, no podrá conectarse. Lo explicaré más tarde.

Hola FTP

Ya configuramos nuestro servidor, ahora vamos a cerrar la ventana de administración. No hay que preocuparnos, el servidor ya está activo y escuchando.

El servidor aceptará conexiones FTP, no importa de cuál sistema operativo (mientras el cliente esté en nuestra red, claro está). Así que podemos conectarnos desde Linux, Mac OS o Windows. En este caso usaré Windows, con el cliente FileZilla client.

Lo abriré y así debe verse:

Como se puede observar, me estoy conectando a localhost o 127.0.0.1. En el usuario puse el usuario que configuré antes, en la contraseña igual.

Y finalmente el puerto… como dije hace un momento, el puerto que mencionamos arriba es para administrar el servidor. Pero recordemos que el puerto para FTP es el 21, por lo que pondremos ese. Una vez puesto esto, hacemos click en Conexión rápida.

En el log podemos ver que se ha conectado correctamente. Y al listar los directorios vemos esto:

Ese es el contenido de mi carpeta Documentos. Ahora puedo hacer click derecho y crear un directorio:

Al hacer click en Aceptar la carpeta es creada. Y si veo los directorios de nuevo:

Ahora recordemos que no dimos permisos de eliminar. Por lo que para probar, intentaré eliminar la carpeta que hice:

Y en el log saldrá esto, indicando que no tengo permiso de hacerlo:

Finalmente quiero demostrar que si desde el explorador de Windows quisiera ver mis documentos, la carpeta que creamos desde filezilla estará ahí:

Conclusión

¿Y para qué sirve todo esto? ¿No puedo administrar mis documentos simplemente desde el explorador de Windows? Claro que sí, pero este fue un ejemplo en donde nos conectamos a localhost. Si después, desde otra pc queremos conectarnos al servidor, simplemente ponemos la ip del servidor en lugar de 127.0.0.1.

Es decir, puede que la ip de tu máquina sea 192.168.1.67. Entonces en la pc que se conectará, pones esa dirección en lugar de 127.0.0.1. Los puertos y usuarios no cambian.

Nota: para esto debes permitir a FileZilla server pasar por el firewall de Windows.

¿Y si quiero acceder desde internet? también se puede, sólo tienes que abrir los puertos de tu módem. De igual manera, sólo cambia 127.0.0.1 por tu ip pública, que puedes encontrar por ejemplo aquí. Si tienes dudas, llama a tu proveedor de servicios de internet.

¿Para qué usar FTP, si puedo usar la red de Windows? si tenemos una pc que no tiene Windows, podemos tardar un poco configurando la red. Así que mejor usamos un cliente FTP. Además, (creo) existen clientes FTP incluso para móviles, por lo que podremos, por ejemplo, subir y bajar archivos desde Android o iOS.

Eso es todo por hoy.