Imprimir en impresora térmica desde Linux

Instalar impresora térmica en Linux para imprimir

Hoy te mostraré cómo instalar una impresora térmica en el sistema operativo Linux, específicamente en Ubuntu (aunque cualquier derivado de Debian debería funcionar) y cómo imprimir en ella de manera sencilla.

Yo probaré con la impresora térmica XPrinter 58 también conocida como ZJ-58, misma que es una impresora económica de 58 milímetros.

Mi sistema operativo es elementary OS 5.1.7 basado en Ubuntu, pero te repito: debería funcionar en cualquier Linux.

Por cierto, esto requiere que el sistema cuente con usblp.

(más…)

Referencia - Lado azul del conector de la cámara junto a conector de audio

Conectar e instalar cámara en Raspberry Pi 4

En este post te mostraré cómo conectar la cámara que dice “Rev 1.3” a la Raspberry Pi 4. Es básicamente una cámara que no se conecta por USB. Te enseñaré fotos para que puedas guiarte sobre la conexión.

Cámara rev 1.3 y Raspberry Pi 4

Cámara rev 1.3 y Raspberry Pi 4

Finalmente te enseñaré cómo habilitar la cámara y tomar fotos en la Pi. Por cierto, en el tutorial voy a suponer que usas Raspbian.

(más…)

Por parzibyte, hace

Instalando OpenCV en Raspberry Pi 4

Al hacer unas pruebas con OpenCV usando una Raspberry Pi 4 y Python, me aparecieron varios errores como:

ImportError: libgtk-3.so.0: cannot open shared object file: No such file or directory

Y luego otro que decía algo sobre liblapack3, así como libcblas.so.3 y muchos más. Después de instalar varias dependencias vengo a mostrar aquí lo que me funcionó.

El sistema operativo que usé es Raspbian, con Python 3 y PIP instalados.

(más…)

Por parzibyte, hace
Demostrar capacidades del plugin para impresoras térmicas

Instalación y uso del plugin para impresoras térmicas V2

Este artículo describe la documentación del plugin para impresoras térmicas versión 2. Aquí se detalla cómo descargar y usar el plugin para la impresión directa desde la nube (aunque técnicamente se hace del lado del cliente).

Recuerda que este plugin no es para nada compatible con la versión 1, así que olvida todo lo que sepas sobre la versión anterior.

(más…)