Solución al error stk500_getsync() attempt 10 of 10 not in sync resp=0xd1 – Arduino

Ayer intenté subir un pequeño sketch muy básico a un Arduino y me encontré el error mencionado en el título.

Solución

La solución era muy simple. Anteriormente usaba un Arduino Uno, pero ahora estaba experimentando con un Mega. Intenté subir el programa y tardaba mucho, hasta que lo desconecté y apareció ese error. Seguí intentando y al final me di cuenta de que simplemente tenía que seleccionar la placa correcta en el editor:

Otras soluciones

El problema que experimenté es muy poco común, ya que cuando este error aparece normalmente las causas son:

  • Un cable conectado al pin 0 (RX). Simplemente cambia de pin si no es necesario que lo uses. De hecho no es recomendado usar el 0 y el 1 para cosas simples o que no necesitan estrictamente esos puertos.
  • Puerto COM erróneo. Asegúrate de elegir bien el puerto, y si no funciona en uno, prueba con los demás.
  • Drivers o controladores no instalados o actualizados. Puedes ir al administrador de dispositivos de Windows y desde ahí actualizarlos.

Referencias

Si sirve de algo, aquí dejo el enlace en donde, al ver los comentarios, encontré la solución a mi problema: http://www.instructables.com/id/A-solution-to-avrdude-stk500getsync-not-in-syn/

 

1 pensamiento sobre “Solución al error stk500_getsync() attempt 10 of 10 not in sync resp=0xd1 – Arduino”

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *